NPSOL is not available?

regFit ← mxRun( regModel, intervals=FALSE)
Running Regression101 with 3 parameters
Error in runHelper(model, frontendStart, intervals, silent, suppressWarnings, :
NPSOL is not available in this build. See ?omxGetNPSOL() to download this optimizer

1 Like

Are you running at home or on the Workshop cloud?

Jeff’s question , “Are you running at home or on the Workshop cloud?”, is an important consideration here. If you’re running OpenMx on the Workshop’s RStudio cloud, then you should not be seeing that error message. If you are not running OpenMx on the Workshop cloud, then you are probably seeing that error message because you installed OpenMx from CRAN, and not from the OpenMx Team’s package repository.

See here for instructions on how to install an NPSOL-enabled OpenMx build. Note that there is presently no NPSOL support for certain platforms, particularly ARM CPUs.

Also, if you are running R version 4.2.0 and run into difficulty, let us know!

1 Like

Also, if you merely want a workaround for that error message, you can do

mxOption(NULL,"Default optimizer","SLSQP")

or

mxOption(NULL,"Default optimizer","CSOLNP")

.

3 Likes