Installation problems with GCTA in mac system


I don’t know whether this is a good place to ask about the question of the installation of GCTA. I have tried to run GCTA and LDSC on my own laptop which is macbook with OS system for the practical. However, it seems that I could not install it correctly in many ways, so I would like to ask for your help.

I downloaded this version of GCTA file " Linux gcta_v1.94.0Beta_linux_kernel_3_x86_64" to my computer and stored it in my working directory where I have the practical data files. Then I run these codes in my terminal (I don’t know the difference between this terminal and linix system):


But it gave me this error msg: No such file or directory.

I tried the following codes again:

cd gcta_v1.94.0Beta_linux_kernel_3_x86_64

The same error message appeared. I have tried to downloaded the mac version of GCTA and rerun the above codes, and it gave me the same error message.

So what is wrong with my installation of GCTA? I appreciate if you could give me any suggestions.



You will have to use the MacOS version of gcta. You can probably unzip it using finder, and then run it at the command line with ./gcta64 If when you try it says “permission denied” then that means you probably need to set the file to executable. You can do that with the command chmod 755 gcta64 (from within the directory that has gcta64 in it).

You can get the MacOS version on the download page. I’ve never tried running it on a Mac, so I don’t know how well it works.